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TENTANG DATA ANALYTICS



PENGERTIAN DATA ANALYTICS

Data analytics adalah aktivitas menganalisa data yang berasal
dari berbagai sumber, dengan jenis dan ukuran yang berbeda
untuk mendapatkan “kesimpulan”.

Hasil kesimpulan yang didapatkan akan membantu institusi
untuk memutuskan keputusan bisnis berdasarkan data yang
tersedia, yang dapat membuat hasil keputusan lebih efektif dan
akurat untuk kemajuan bisnis kedepannya.
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End Users
• Customer Data

• Transaction Data

• Manpower Data

• Financial data

One platform to analyze  
& visualize

Valuable insights
• Micro and macro picture

• Predict consumer trends, marketing  
trends & behaviours etc

• Historical data

• Actual vs target

How Business Intelegence Platform
Solve the problem in industry



Benefits of
Business Intelligence Tools



Top 5
Business Intelligence Tools

KNOW AS Power BI Tableau Qlick Sense SAP Analytical Cloud IBM Cognos Analytics

RELEASED 2015 2003 1994 2015 2009*

FOUNDERS
• Thierry D'Hers
• Amir Netz
• Ron George

• Christian Chabot
• Chris Stolte
• Andrew Beers
• Pat Hanrahan

• Bjorn Berg
• Staffan Gestrelius - -

DEVELOPER Microsoft Salesforce Inc. Qlick SAP IBM

WEBSITE powerbi.microsoft.com tableau.com Qlick.com Sap.com
ibm.com/products/co
g  nos-analytics

PRODUCTS Desktop and 
web- based

Desktop and
web- based

Web-based Web-based Web-based



Market Share
Business Intelligence Tools

Source : TrustRadius (2021 ) Source : Gartner (2021)

Source : Google Trends (2021 )



PENGENALAN POWER BI



Power BI

• Microsoft Power BI adalah kumpulan dari software services, apps, dan
connectors yang bekerja sama untuk mengubah sumber data yang tidak
berelasi ke dalam suatu insight yang koheren, interaktif, dan menarik
secara visual.



Ms. PowerBI
Compare to Tableau

COST + Rp 150.000/month/users
+ Rp 980.000/month/users (Creator)
+ Rp 168.000/month/users (Viewer)

STRENGTH Flexibility and Development Appearance and Interactivity

TRANSFORM
Use Power Query on the back end and linking data
tables

Use Tableau Prep for transform data (quite cumbersome for
handle data transformation)

CALCULATION Can do extensive calculation using DAX
Easy to use quick measure but quite cumbersome for 
custom calculations

VISUAL Flexibility to use custom visuals and relayouting visuals
Well-designed and focus on building visuals before turn 
into  dashboard

PRODUCTS
Power BI Desktop, Power Bi Service, Power BI Mobile
Apps, Power BI Gateway, and Power BI Report Server

Tableau products include Tableau Desktop, Tableau Server,  
Tableau Online, Tableau Vizable, Tableau Public, and 
Tableau  Reader



Ms. PowerBI
Compare Ms. Excel

Power BI is much more complete than Excel in terms of  
connectivity. It can access and extract data from virtually any  
system or application and is designed to work in the cloud

1.

Power BI facilities collaborative and manage datasets.  
Through Power BI Service, files can be published and all  
organization member can work with same datasets to create  
new reports

Better for Governed
Data

2.

One of the great advantages of Power BI is that it updates  the 
data automatically, so that if a file contains changes in the  data 
or new data, it will not have to be reloaded. In Excel,  however, 
this should be refresh manually

Automatic
Update

3.

Power BI has the capacity to handle large amounts of data

Designed for Big Data

Share the dashboard by link or embed to website. Users can
easily access the dashboard from all device and any time

Ideal for Dashboards and KPIs

Power BI is the ideal program for creating personalized and  
interactive dashboards. Power BI visualization are much more  
attractive and impactful. In addition, Power BI visuals can  
connect to data models and analyze data visually

Easy to Share and Publish

4.
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6.

Superior Connectivity



Types of
Ms. Power BI

1. Power BI  
Dekstop

2. Power BI Web  
Service

3. Power BI Apps



INSTALASI POWER BI

• Microsoft Store -> Search Power BI Desktop



POWER BI DESKTOP



Bagian Utama Power BI

• Power BI Desktop  yang akan kita gunakan
• Power BI service  layanan Saas (Software as a Service)
• Mobile Power BI apps  aplikasi untuk perangkat bergerak



Workflow dalam menggunakan Power BI

Power BI 
Desktop

Power BI 
Service

Power BI 
apps



Building block dalam Power BI
• Dataset

Koleksi data yang dipakai Power BI untuk membuat visualisasi. 
Data dapat diperoleh dari Excel, JSON, web, dll.

• Visualisasi
adalah representasi visual dari data, seperti grafik, peta warna, atau bentuk
visualisasi yang lain.

• Reports
Kumpulan visualisasi yang muncul di dalam satu atau beberapa halaman.

• Dashboard
Kumpulan koleksi dari visualisasi di dalam suatu halaman yang dapat di-share
ke orang lain.

• Tiles
Elemen visualisasi tunggal di dalam report atau dashboard.



Datasets

Visualization

Report

Dashboard

Datasets is a colection of data or information. It can be simple datasets or
many  combination of differencesources

Power BI
Building Blocks





Report

Dashboard

Visual representations of data. At this state, the most important is that
every  chart or graph has specific contex and objective.

Example: Bar chartand BubbleChartDatasets

Visualization

Power BI
Building Blocks





Datasets

Visualization

Report

Dashboard

Report is a collection of visualizations that appear together on one or
more  pages.

Power BI
Building Blocks





Datasets

Visualization

Report

Dashboard

Dashboard is compressed version of many reports, contain the most
important  elements of reports to tel thestory

Power BI
Building Blocks





Tiles



Each column must have a heading

No blank heading

No duplicate heading

No merged cells

No formula in headings

One column – one meaning 

No blank cells

Prepare
The Good Data Checklist



POWER BI DEKSTOP



UI of Power BI

v

Sign in account

Field Panel
Where the datasets

come up

Visualization  
Panel

To visual the data or  
format it

Filter Panel
Filtering data that show  

on canvas

MENU

Ribbons
To transform  
the visuals

Views
• REPORT
• DATA
• MODEL

CANVAS

v

v

Another option to connect the 
data  source



How to Fomat Canvas
On Power BI Desktop

Before you spend of much time in project,  
we recommend you to complete the  
information, decide the size of canvas or  the 
background. Here is the steps how to

1. Select the Format Button
2.On the top is information of the page, in  

here you able to rename the page,  format 
the page as tooltip (we’ll talk  about it 
later), or as Q&A

3.The second is Page Size, where you can  
adjust the page size that suit with your  
requirements. The default of canvas  Power 
BI is 16:9 ratio, but you can  custom by 
select the option

4.Another format is Page Background to
make you dashboard more stunning of
Page Allignment

1

2

v
3

v4



Data Souce Connectors
On Power BI Desktop

With Power BI Desktop, you can 
connect to data from many 
different sources. For a full list of 
available data sources

You connect to data by using  
the Home ribbon. To show the 
Most Common data types 
menu, select the Get data 
button label or the down arrow

In total there are 135 data  
connectors that available  
per January 2022

v
1
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PERSIAPAN DAN TRANSFORMASI DATA



MENGAMBIL DATA

Ada 2 cara:
1. Melalui menu Home -> Get Data -> Pilih Jenis Datanya -> Connect -
> Pilih datanya -> Ok

2. Transform Data -> New Source -> Pilih Jenis Datanya -> Connect -> 
Pilih datanya -> Ok -> Cek Datanya -> Close and Apply

Latihan:
Masukkan data Laporan Penjualan PT.ABC



QUERY EDITOR
1. Mengganti nama tabel dengan cara klik 2x pada nama tabel, kemudian

masukkan nama table yang baru.

Latihan:

– Ganti nama-nama table pada data Laporan Penjualan PT.ABC

2. Periksa kolom header pada table terdapat icon yang menandakan tipe data 
dari kolom tersebut.

– Bila ingin mengganti tipe datanya, maka klik pada iconnya.

3. Cek seluruh tipe data setiap kolom apakah sudah sesuai atau belum.

4. Jika sudah sesuai, ke menu Home -> Close & Apply

Latihan: 

Periksa tipe data semua kolom pada semua table Laporan Penjualan PT. ABC



QUERY EDITOR LANJUTAN

• Data yang masuk ke dalam Power BI Desktop biasanya banyak yang berantakan dan 
perlu dirapikan.

• Menu-menu yang penting:
– New source
– Remove column
– Remove row
– Split column
– Transform:

• Use first row as header
• Data type
• Split column
• Queries : delete, rename, move to group, move down



Latihan:

• Transform Data -> New Source -> Excel Workbook -> Budget PT.ABC -> cek table budget pada menu Navigator -> ok

• Pada applied steps, hapus langkah-langkah yang tidak dipakai

– Changed type

– Promoted headers

• Cek data

• Hapus baris dan kolom yang tidak digunakan / mengandung nilai null

• Hapus 3 baris teratas

• Remove rows -> remove top rows -> masukkan berapa rows

• Hapus kolom yang tidak diperlukan

– Klik kanan -> remove

– Filter

• Merubah baris pertama menjadi header

• Use first row as header

• Memindahkan kolom menjadi baris

• Transform -> Unpivot Column

• Mengganti tipe data



Mengambil Data Webpage

• Pada tahap ini, kita akan belajar mengambil data yang berasal
dari halaman web menggunakan Power BI.

• Kemudian kita akan melakukan data shaping
– Mengubah format data agar sesuai dengan data yang disimpan
– Memilih beberapa kolom untuk ditampilkan visualisasinya

• Sumber data:
https://www.bankrate.com/retirement/best-and-worst-states-
for-retirement/



Connect to Web on Power BI Dekstop

• Pilih menu Get Data | Web



Connect to Web on Power BI Dekstop

• Masukkan URL web ke dalam form untuk melakukan download 
data



Mengambil Data File Excel

• Selain dari web, kita dapat mengimport file Ms Excel, Ms Access, JSON 
ke dalam Power BI

• File yang terimport akan menjadi sebuah tabel. Jika terdapat beberapa
worksheet, maka akan terimport menjadi beberapa tabel.

• Buat file Power BI baru. Kemudian pilih menu Get Data > Excel dan pilih
file Canada.xlsx



Import Excel

• Hasil import



Import Excel

• Dari data tersebut, kita dapat melakukan berbagai visualisasi



Transform Data
On Power BI Desktop

The Query Editor in Power BI is used to 
transform  or edit data files before they 
are actually  loaded into the Power BI.

The Query Editor plays the role of an 
intermediate  data container where you can 
modify data by  selecting rows and 
columns, splitting rows  and columns, 
pivoting and unpivoting  columns, etc.

The changes made by the Query Editor in 
Power BI  are not reflected in the actual 
dataset. Once you  have pre-processed the 
data and have transformed  it into the 
required format, you can load the data  into 
the Power BI environment.



How toChange Data Source Location

• If the data source location is changed for  some 
reason, then you need to setup the new  location. This 
because when you refreshed,  Power BI will review the 
location path and file  name. So to avoid error you need 
to do it.

1. Select Transform Data on Home Menu
2. Select Data Source Settings
3. Select the source data list that you want to change
4. Select Change Source
5. Select Browse to find the new location or  file
6. OK

3
.

1

2

3

4

5

6



PENGOLAHAN DATA



Pengolahan Data (1)
• Pilih tabel yang diinginkan pada panel sebelah kiri. Di sini kita

menggunakan “Ranking of the best and worst states for retirement”
• Klik tombol refresh pada pojok kanan atas apabila tabel tidak muncul.



Pengolahan Data (2)

• Klik tombol “Edit” untuk masuk ke dalam mode Power Query



Pengolahan Data (3)

• Akan muncul tampilan Power Query seperti berikut.
• Pada langkah berikutnya, kita akan mengubah tipe data pada beberapa kolom agar 

sesuai dengan data yang disimpan pada kolom tersebut data shaping.



Pengolahan Data (4)

• Pada umumnya, Power BI akan otomatis mendeteksi tipe data dari sebuah kolom.
• Apabila ada kesalahan deteksi, maka ubah tipe data kolom dengan cara klik kanan

kemudian pilih Change Type



Pengolahan Data (5)

• Kita akan menambahkan data singkatan State yang biasanya
terdiri dari dua huruf.

• Untuk mendapatkan data singkatan tiap State, kita akan
mengambilnya dari Wikipedia.
https://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations



Pengolahan Data (6)

• Pada window Power Query Editor, pilih menu 
New Source > Web

• Kemudian masukkan link Wikipedia tersebut.



Pengolahan Data (7)

• Pilih tabel pertama, kemudian klik OK.



Pengolahan Data (8)

• Lakukan data cleansing. Pada tahap ini, hapus 3 baris teratas karena data tersebut
tidak dipakai.

• Caranya yaitu pilih menu Remove rows > Remove Top Rows.



Pengolahan Data (9)

• Pada tahap berikutnya, hapus 26 baris terbawah karena data tersebut tidak dipakai.
• Caranya yaitu pilih menu Remove rows > Remove Bottom Rows.



Pengolahan Data (10)

• Filter data “Federal district” dari kolom Name and status of 
region2



Pengolahan Data (11)

• Hapus kolom yang tidak diperlukan. Kita hanya memerlukan kolom kedua dan kelima.
• Pilih kolom-kolom lain selain kolom kedua dan kelima dengan cara Ctrl + klik kolomnya.
• Kemudian pilih menu Remove Columns > Remove Columns.



Pengolahan Data (12)

• Ubah baris pertama sebagai header dengan memilih menu 
Use first row as headers



Pengolahan Data (13)

• Ubah nama kolomnya menjadi State Name dan State Code
• Caranya dengan cara double click pada nama kolomnya



Pengolangan Data (14)

• Ubah nama tabel menjadi StateCodes.



Pengolahan Data (15)

• Setelah kita memiliki dua buah query tersebut, kita dapat
menggabungkannya menjadi satu.

• Mekanisme penggabungan
– Merging

Menambahkan kolom dari salah satu query ke query yang lain
– Appending

Menambahkan baris data dari satu query ke query yang lain



Pengolahan Data (16)

• Pilih menu Merge Query
• Pilih query pertama dan klik kolom

State
• Pilih query StateCodes dan klik kolom

State Name



Pengolahan Data (17)

• Klik tombol expand pada kolom yang ditambahkan.
• Hapus centang pada State Name dan Use original column name as 

prefix.



Pengolahan Data (18)

• Pilih menu Close & Apply > Close & Apply untuk menyimpan
hasil edit query.



Pengolahan Data (19)

• Pilih menu File > Save As
• Simpan project dengan nama “Getting Started with Power BI 

Desktop.pbix”



0813 12000 913 |    RahadianN@unkris.ac.id

• https://powerbi.microsoft.com/en-us/learning/

• https://docs.microsoft.com/en-us/power-bi/guided-learning/

• https://community.powerbi.com/

• https://www.edx.org/course/analyzing-and-visualizing-data-
with-power-bi

• https://vladmihalcea.com/database-table-relationships/

TERIMA KASIH..
SAMPAI JUMPA LAGI..
WASSALAMUALAIKUM. WR. WB.



DATA ANALYTICS
Power BI



Assalamualaikum. Wr. Wb.

Rahadian Nopriantoko, S.Si., M.Si. 

• Alumni S1 & S2 Universitas Indonesia

• Dosen di Universitas Indonesia 2016-2018 & 
Universitas Krisnadwipayana 2018-Sekarang

• Selain dosen juga berkhidmat sebagai
profesional, konsultan, instruktur, trainer, dan
mentor

• Dapat dihubungi via WA 0813 12000 913 dan
Email RahadianN@unkris.ac.id



Agenda

1. Tentang Data Analytics
2. Pengenalan Power BI
3. Power BI Dekstop
4. Persiapan dan

Transformasi Data
5. Pengolahan Data
6. Membuat Visualisasi

7. Deployment Visuals
8. Modeling
9. Pengenalan DAX
10. Publishing and Sharing
11. Power BI Service
12. Guidance and Tips



MEMBUAT VISUALISASI



Is Data Viz easy?

it's not simply as easy as just dressing up 
a  graph to make i t  look better or 
slapping on  the “ info”  part of an
infographic.

Effective data visualization is a delicate  
balancing act between form and
function



Be a Data Visualizer
The Mindset You Must Have

As a Data Visualizer, often you will meet an ambiguous  
problems. To do deliver the right solutions, you have to  
gather information from the user about what they want and  
need.

1.

There are tons ways to visualize your data. As Data Visualizer,  
you have to wisely choose the right and effective visuals to  
represent the data and tell the right story.

Choose the Effective Visuals2.

In visuals, often you will found elements (suca as grid lines)  
that will distract your audiences (users). You have to remove  
that elements or, if necessary, add an element to focus your  
audience (like target line).

Focus Your Audience3.

Data Visualizer is a mix subject between data expertise and  
art. Besides you are an engineer, you have to have a mindset  
like a designer to deliver your story in your data.

Understand The Context Think Like a Designer

Visual is not always about showing a good visuals. You also  
have to tell the right story from your visuals. So that the  
visuals can speak the data the way we wanted to.

Tell The Story

From all the mindsets mentioned above, putting it together in  
yourself. Learn from the mistakes as more projects you  handle 
and stay thirsty for a new knowledge.

Putting it
Together

4.
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6.



Data Visualization
Use the Right Visuals



Report Menu

• Pada menu Report terdapat 5 bagian utama:
1. Ribbon yang berisi menu-menu umum
2. Report view, di mana visualisasi dibuat dan ditata
3. Pages tab, untuk menambahkan halaman baru
4. Visualization pane, untuk mengganti aspek visual (warna grafik, 

apply filter, dll.)
5. Field pane, yang berisi elemen query yang dapat di-drag ke dalam

Report ataupun Filters.



Report Menu



Membuat Visualisasi (1)

• Tambahkan sebuah Fields ke dalam Report view
• Caranya yaitu drag field State dari query Ranking ke area kerja

Secara otomatis, Power BI akan
menampilkan peta sesuai dengan
data kolom tersebut.



Membuat Visualisasi (2)

• Tambahkan Overall rank
dari Fields pane ke dalam
Color saturation pada
Visualization pane

• Kemudian ubah mode peta
menjadi Filled Map



Membuat Visualisasi (3)
• Tambahkan visualisasi kedua dengan melakukan drag State dari Ranking query pada area kosong.
• Kemudian tambahkan Overall rank, Health care quality, dan Well-being ke dalam visualisasi

tersebut.
• Ubah visualisasi menjadi Line and clustered column.



Membuat Visualisasi (4)

• Pindahkan Well-being ke dalam Line values



Visualisasi

• Power BI menyediakan banyak pilihan visualisasi data.
• Contoh:

– Pie chart
– Maps
– Tabular format
– Matrix
– Waterfall
– Funnels
– Gauges
– Dll.



Pie Chart

• Legend:
Locations.Region

• Values:
Sales.Total Units



Tree Map

• Group:
Manufacturers.Ma
nufacturer

• Values:
Sales.Total Units



Filter (including Top N)

• Dari visualisasi Tree Map yang sebelumnya kita dapat melakukan
visualisasi dengan memilih Top N manufacturer.



Filter (including Top N)

• Kemudian tambahkan filter Top N (5) dengan value Total Units



Line and Stacked Column Chart



Slicer

• Kita dapat menambahkan Slicer untuk menampilkan data sesuai dengan kategori yang 
dipilih.

• Untuk memilih beberapa slicer sekaligus, klik Ctrl + item slicer



Scatter Chart



Deployment Visuals
Power BI Desktop



Tooltip
Basic of Tooltip

Tooltips appear when the cursor is  
hovering over a visual.

• You can use tooltips so that they can provide  
contextual help like they hind and message to  
your report for decisions.

• Users usually don’t work what they don’t  
understand. Tooltips help the users to understand  
the complex features of the system.

• A tooltip will help to find our accurate data and
assist them in form fields

1

You are able to add
more information inside Tooltip

2

Here is the steps to add more information inside the  
tooltip:

1. Add the dimension of data that we want to show on
tooltip from Field Pane then drop to Tooltip Field

2. The information will automatically show up on the  
tooltip

Basic tooltip



Tooltip
Create a Custom Tooltip

1. Create a new Page
2. Within that page, navigate to the Format pane and  

expand Page Size. Within Page Size, select Type to be  
Tooltip

3. Next, go to the Page Information section and make sure
Tooltip is set to on

4. Now start building your Tooltip. You can use any  
combination of visuals for that. It’s just like  
creating a report in Power BI

5. Finally, apply this to the chart you want to use.  
Navigate to your chart and select it. Now turn the  
Tooltip on and under Page select the Tooltip you just  
created

2 3 4

5

Custom Tooltip



Filter Panel
Level of Filter Panel

Filters also refine the data;  however, 
they are designed as a  tool for 
developers to configure  visuals before 
the dashboard is  provided to
consumers

There are three different kinds of  
filters, all of which are configured  using 
the Filter’s panel to the right  of the 
canvas and include:

1. Filter level visual
2. Filter level page, and
3. filters that apply to all pages

Filter apply to visual

Filter apply to page  
(multi visuals)

Filter apply to all  
pages (multi pages)

1

2

3



Filter Panel
Types of Filtering

Configurations for filters are the  
same for each of the three kinds of  
filters. However, they are different  
depending on the datatype :
• String
• Number, or
• Date

Select the filter type by clicking on  
the dropdown box in the filter panel

• Advanced filtering: filter  
based on custom string logic  
for the dimension.

• Basic Filtering: select  
which values of the  
dimension to include
or exclude

• Top N: filter the dimension  
to the top (or bottom) value  
of N, based on another field  
from the field list. N is a  
variable that you will specify.

Type of Filtering for
String Values

Type of Filtering for
Number Values

See the screenshot  
above for the list of  
customized logic that can  
be chosen when using a  
number value. Select any  
of these and then specify  
a variable to apply to the  
filter

• Advanced, Basic, and Top N
filtering are available for date
values.

• Relative date: filter based on
a set variable for the options in
the screenshot below based on
days, weeks, months, or years.

• Relative time: filter based on
a set variable for the options in
the screenshot below based on
hours and minutes

Type of Filtering for
Date Values
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Format Visual
Insert Picture

You can also add a picture in your dashboard as  
simply as you could do in Microsoft Excel or  
Word.

1. Click Insert Menu and choose Image.
2. Browse and choose your picture file to be  

inserted in your dashboard, then click Open.
3. Adjust the size of your picture.

Pictures and Icons also can be used as  
page navigation or bookmarks button.

You can browse for more pictures or icons for  
free with these two websites:
1. https://www.flaticon.com/
2. https://www.freepik.com/

Use it wisely and be aware about the  
copyrights of pictures and icons you used.
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Format Visual
Add Shape

You add a shapes in your
dashboard

1. Click Insert Menu and choose
Shapes.

2. Choose the shape which you 
want to insert in  your
dashboard.

3. Adjust the size, the color, or the 
text you want  to be inserted in 
your shape.

4. Shapes also can be used as page 
navigation  or bookmarks button.
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Format Visual
Manage Your Objects Order

Sometimes you have to deal with visuals 
or  objects that overlap each other, and 
you can't see  important information 
because of it. You can  change the order 
of all your objects so that you  can decide 
which object will be on top of another  
object.

1. Click View Menu and choose Selection.
2. In Selection panel you can drag which 

object  will be on top of another.

Be aware that the order of objects in  
Selection panel determine the position of  
an object from another objects.

1
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Format Visual
Change and Import Themes

In some cases, you want Power BI to 
determine  the colors and fonts style 
theme of your  dashboard

Power BI can help you to 
determine the color  theme you 
can use or download for more  
themes:
1. Click View menu and click the 

theme box.
2. Choose your theme.
3. Check Theme gallery to download 

more  theme options from 
community. Download the  ".json" 
file type.

4. Install the new downloaded theme.
.
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Insert Summary
Using Smart Narrative

The smart narrative visualization helps you quickly  
summarize visuals and reports. It provides relevant  
innovative insights that you can customize.

Smart Narrative

Use smart narrative summaries in your reports to address  
key takeaways, to point out trends, and to edit the  
language and format for a specific audience.

Your audience can use the summaries to understand the  
data, get to key points faster, and explain the data to  
others.

To generate a smart narrative of a visualization, right-click it and then
select Summarize. For example, in the sample file, try summarizing a scatter chart  
that shows various transactions

1. In the Visualizations pane, select the Smart narrative icon to automatically  
generate a summary. For example, in the sample file, smart narratives can  
automatically generate a summary of the report's visuals that address revenue, website  
visits, and sales



Insert Summary
Custom The Smart Narrative

The smart narrative summary is highly customizable. You  
can edit or add to the existing text by using the text box  
commands. For example, you can make the text bold or  
change its color.

1. Click the Smart Narrative. The new tab will appeare like  
above

2. Select the "(+) Value" to add dynamic value
3. Write the value that you want you to add
4. Rename the value
5. Select SAVE
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Concideration & Limitition

• Cards with non-numeric measures
• Tables, matrices, R visuals or Python visuals,

custom
visuals

• Cross-filtering out of a visual
• Renaming dynamic values or editing 

automatically  generated dynamic values
• Summaries of visuals that contain on-the-fly  

calculations like QnA arithmetic, complex 
measures  such as percentage of grand total 
and measures  from extension schemas

TIPS :

Combine Smart Narrative  
to the Tooltip



Format Visual
Make Mobile Layout

If you want your dashboard appear 
properly in  mobile phone, you have to 
design your visuals in  Mobile Layout.

1. Choose View menu then click Mobile
Layout.

2. You will be directed in a new
canvas which has been adapted to
the appearance of the handphone.
Drag your visuals to the canvas
and adjust the size of the visuals.

3. This appearance will be triggered if 
you open  your workspace in Power 
BI apps in your  smartphone. (can 
be found in Play Store)

1
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Drag &
Drop
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